有ie浏览器的兼容性问题吗

发布于 2020-10-24 10:33
共2个回答
NV
游客nvRbwh

没有测试过,但根据package.json的browserslist信息是支持IE > 8,但需要添加babel-poyfill。

  "browserslist": ["> 1%", "last 2 versions", "not ie <= 8"],
TJ
游客TJiGkg

支持的,最低支持IE9,需要使用babel-poyfill。

安装babel-polyfill

yarn add babel-polyfill -D

babel.config.js配置:

module.exports = {
  presets: [
    '@vue/app'
  ]
};

然后在项目入口文件引入

import 'babel-polyfill'

更多信息可参见:https://cli.vuejs.org/zh/guide/browser-compatibility.html#usebuiltins-usage

这是效果 image.png

回答问题